Vulnerability · Published Oct 14, 2026 · Assigned by GitHub_M

CVE-2026-53615util-linux libblkid DOS extended-partition overflow produces invalid partition metadata

High 8.0

In plain English

A high-severity integer overflow in util-linux from util-linux. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)0.2%top 92.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

util-linux is a random collection of Linux utilities. Before util-linux 2.41.4, `parse_dos_extended()` in `libblkid/src/partitions/dos.c` computes an extended-partition start sector with 32-bit addition and does not apply the extended-area bounds checks to the first two EBR entries. A local attacker who causes a crafted DOS extended-partition disk image or removable medium to be probed can wrap `cur_start + start` to sector zero and cause libblkid to report a false partition overlapping the MBR. This directly compromises the integrity of the reported partition metadata; disk modification or availability loss requires a separate downstream consumer to act on that metadata. This issue is fixed in 2.41.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10libblkid2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libblkid-devel2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libfdisk2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libfdisk-devel2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libmount2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libmount-devel2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libsmartcols2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libsmartcols-devel2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libuuid2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10libuuid-devel2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10python3-libmount2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10util-linux2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10util-linux-core2.40.2-18.el10_2.20ALSA-2026:93461
AlmaLinux:10uuidd2.40.2-18.el10_2.20ALSA-2026:93461
Debian:12util-linuxno fix listedDEBIAN-CVE-2026-53615
Debian:13util-linux2.41.5-0+deb13u1DEBIAN-CVE-2026-53615
Debian:14util-linux2.42-1DEBIAN-CVE-2026-53615
Rocky Linux:10util-linux0:2.40.2-18.el10_2.20RLSA-2026:93461
Ubuntu:22.04:LTSutil-linux2.37.2-4ubuntu3.6USN-8702-1
Ubuntu:22.04:LTSutil-linux2.37.2-4ubuntu3.6UBUNTU-CVE-2026-53615
Ubuntu:24.04:LTSutil-linux2.39.3-9ubuntu6.6UBUNTU-CVE-2026-53615
Ubuntu:24.04:LTSutil-linux2.39.3-9ubuntu6.6USN-8702-1
Ubuntu:25.10util-linuxno fix listedUBUNTU-CVE-2026-53615
Ubuntu:26.04:LTSutil-linux2.41.3-3ubuntu2.2USN-8702-1
Ubuntu:26.04:LTSutil-linux2.41.3-3ubuntu2.2UBUNTU-CVE-2026-53615
Ubuntu:26.10util-linuxno fix listedUBUNTU-CVE-2026-53615

Affected products (as reported)

VendorProductVersions
util-linux util-linux < 2.41.4

Weakness: CWE-190 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H

References