Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-53550js-yaml: Quadratic-complexity DoS in merge key handling via repeated aliases

Medium 5.3

In plain English

A medium-severity security flaw in js-yaml from nodeca. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.4%top 63.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

js-yaml is a JavaScript YAML parser and dumper. Prior to 4.2.0 and 3.15.0, a crafted YAML document can trigger algorithmic CPU exhaustion in js-yaml merge-key processing (<<) by repeating the same alias many times in a merge sequence. This causes quadratic parse-time behavior relative to input size and can block a Node.js worker/event loop for seconds with a relatively small payload (tens of KB), resulting in denial of service. The issue is in merge handling inside lib/loader.js. This vulnerability is fixed in 4.2.0 and 3.15.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-js-yamlno fix listedDEBIAN-CVE-2026-53550
Debian:13node-js-yamlno fix listedDEBIAN-CVE-2026-53550
Debian:14node-js-yaml4.2.0+~4.0.9-1DEBIAN-CVE-2026-53550
Ubuntu:22.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-53550
Ubuntu:24.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-53550
Ubuntu:25.10node-js-yamlno fix listedUBUNTU-CVE-2026-53550
Ubuntu:26.04:LTSnode-js-yamlno fix listedUBUNTU-CVE-2026-53550
Ubuntu:26.10node-js-yamlno fix listedUBUNTU-CVE-2026-53550
npmjs-yaml4.2.0GHSA-h67p-54hq-rp68
npmjs-yaml3.15.0GHSA-h67p-54hq-rp68

Affected products (as reported)

VendorProductVersions
nodeca js-yaml >= 4.0.0, < 4.2.0< 3.15.0

Weakness: CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References