Vulnerability · Published Jul 1, 2026 · Assigned by GitHub_M
CVE-2026-53488containerd CRI plugin: — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull
Critical 9.4
In plain English
A critical-severity improper input validation in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
containerd is an open-source container runtime. In versions prior to 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10 the CRI plugin propagates labels from an image config (LABEL instruction in Dockerfile) to a container without validation. This may result in executing an arbitrary command on the host, via a plugin that consumes container labels for some operations. This issue has been fixed in versions 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.24 | containerd | 2.3.2-r0 | ALPINE-CVE-2026-53488 |
| Debian:12 | containerd | no fix listed | DEBIAN-CVE-2026-53488 |
| Debian:13 | containerd | no fix listed | DEBIAN-CVE-2026-53488 |
| Debian:14 | containerd | 2.1.9+ds1-1 | DEBIAN-CVE-2026-53488 |
| Go | github.com/containerd/containerd | 1.7.33 | GHSA-xhf5-7wjv-pqxp |
| Go | github.com/containerd/containerd | 1.7.33 | GO-2026-5758 |
| Go | github.com/containerd/containerd/v2 | 2.3.2 | GHSA-xhf5-7wjv-pqxp |
| Go | github.com/containerd/containerd/v2 | 2.0.10 | GHSA-xhf5-7wjv-pqxp |
| Go | github.com/containerd/containerd/v2 | 2.1.9 | GHSA-xhf5-7wjv-pqxp |
| Go | github.com/containerd/containerd/v2 | 2.0.10, 2.1.9, 2.2.5, 2.3.2 | GO-2026-5758 |
| Go | github.com/containerd/containerd/v2 | 2.2.5 | GHSA-xhf5-7wjv-pqxp |
| Ubuntu:22.04:LTS | containerd | 1.6.12-0ubuntu1~22.04.11 | UBUNTU-CVE-2026-53488 |
| Ubuntu:25.10 | containerd | no fix listed | UBUNTU-CVE-2026-53488 |
| Ubuntu:26.10 | containerd | no fix listed | UBUNTU-CVE-2026-53488 |
| Ubuntu:22.04:LTS | containerd-app | 2.2.1-0ubuntu1~22.04.2 | UBUNTU-CVE-2026-53488 |
| Ubuntu:24.04:LTS | containerd-app | 2.2.1-0ubuntu1~24.04.3 | UBUNTU-CVE-2026-53488 |
| Ubuntu:25.10 | containerd-app | 2.2.1-0ubuntu1~25.10.2 | UBUNTU-CVE-2026-53488 |
| Ubuntu:26.04:LTS | containerd-app | 2.2.2-0ubuntu1.1 | UBUNTU-CVE-2026-53488 |
| Ubuntu:25.10 | containerd-stable | 2.1.6-0ubuntu1~25.10.2 | UBUNTU-CVE-2026-53488 |
| Ubuntu:26.04:LTS | containerd-stable | 2.2.2-0ubuntu1.1 | UBUNTU-CVE-2026-53488 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| containerd | containerd | < 1.7.33>= 2.0.0, < 2.0.10>= 2.1.0, < 2.1.9>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.2 |
Weakness: CWE-20 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/containerd/containerd/security/advisories/GHSA-xhf5-7wjv-pqxp x_refsource_CONFIRM