Vulnerability · Published Jun 10, 2026 · Assigned by GitHub_M
CVE-2026-53461ImageMagick: Out-of-bounds write in ICON decoder due to incorrect loop
High 7.5
In plain English
A high-severity out-of-bounds write in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 6.9.13-50 and 7.1.2-25, an incorrect loop in the ICON decoder can result in an out of bounds heap write resulting in a crash. This issue has been patched in versions 6.9.13-50 and 7.1.2-25.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | imagemagick | 7.1.2.25-r0 | ALPINE-CVE-2026-53461 |
| Alpine:v3.24 | imagemagick | 7.1.2.25-r0 | ALPINE-CVE-2026-53461 |
| Debian:13 | imagemagick | 8:7.1.1.43+dfsg1-1+deb13u10 | DEBIAN-CVE-2026-53461 |
| Debian:14 | imagemagick | 8:7.1.2.25+dfsg1-1 | DEBIAN-CVE-2026-53461 |
| NuGet | magick.net-q16-anycpu | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-arm64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-hdri-anycpu | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-hdri-arm64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-hdri-openmp-arm64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-hdri-x64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-hdri-x86 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-openmp-arm64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-openmp-x64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-x64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q16-x86 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q8-anycpu | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q8-arm64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q8-openmp-arm64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q8-openmp-x64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q8-x64 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| NuGet | magick.net-q8-x86 | 14.14.0 | GHSA-g22q-f7gc-5jhr |
| Ubuntu:25.10 | imagemagick | no fix listed | UBUNTU-CVE-2026-53461 |
| Ubuntu:26.10 | imagemagick | no fix listed | UBUNTU-CVE-2026-53461 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ImageMagick | ImageMagick | < 6.9.13-50< 7.1.2-25 |
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-g22q-f7gc-5jhr x_refsource_CONFIRM
- https://access.redhat.com/security/cve/CVE-2026-53461 vdb-entry, x_refsource_REDHAT
- RHBZ#2487764 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-53461.json x_sadp-csaf-vex