Vulnerability · Published Jun 30, 2026 · Assigned by apache

CVE-2026-52760Apache ActiveMQ, Apache ActiveMQ Web Console: Stored XSS via Unescaped values in ActiveMQ Web Console

Medium 6.1

In plain English

A medium-severity cross-site scripting in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.7%top 47.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web Console. The browse page in the web console renders a message Id directly without sanitization. This allows an authenticated producer to send a message with a JMS message ID that has been crafted to contain HTML/JavaScript such that when an administrator browses the queue in the Web Console, the payload executes in their browser. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Web Console: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-52760
Debian:13activemqno fix listedDEBIAN-CVE-2026-52760
Mavenorg.apache.activemq:activemq-web-console5.19.8GHSA-j548-68g5-9j7x
Mavenorg.apache.activemq:activemq-web-console6.2.7GHSA-j548-68g5-9j7x
Mavenorg.apache.activemq:apache-activemq5.19.8GHSA-j548-68g5-9j7x
Mavenorg.apache.activemq:apache-activemq6.2.7GHSA-j548-68g5-9j7x
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-52760
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-52760
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-52760
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-52760

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.86.0.0 – before 6.2.7
Apache Software Foundation Apache ActiveMQ Web Console 0 – before 5.19.86.0.0 – before 6.2.7

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References