Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-52725Angular Template and Dynamic Component Namespace Bypass leading to Cross-Site Scripting (XSS)

Medium 5.3

In plain English

A medium-severity cross-site scripting in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.5%top 60.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/core package allows bypassing script-execution restrictions during dynamic component creation. Specifically, the dynamic component instantiation mechanism (createComponent) failed to reject mounting components directly onto a <script> or namespaced script element (such as <svg:script>). This enabled the initialization of custom components on a tag that executes scripts, allowing attackers to hijack or inject script-executing hosts. This flaw enables an attacker who can control the host element or selector parameter passed to createComponent to initialize or mount an Angular component directly onto a <script> tag, leading to execution of untrusted code or client-side Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-52725
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-52725
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-52725
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-52725
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-52725
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-52725
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-52725
npm@angular/core20.3.22GHSA-692r-grfm-v8x7
npm@angular/coreno fix listedGHSA-692r-grfm-v8x7
npm@angular/core19.2.23GHSA-692r-grfm-v8x7
npm@angular/core22.0.0-rc.2GHSA-692r-grfm-v8x7
npm@angular/core21.2.15GHSA-692r-grfm-v8x7

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0 < 22.0.0-rc.2>= 21.0.0-next.0 < 21.2.15>= 20.0.0-next.0 < 20.3.22>= 19.0.0-next.0 < 19.2.22<= 18.2.14

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References