Vulnerability · Published Sep 15, 2026 · Assigned by GitHub_M

CVE-2026-52724kuma-dp connects to control plane without verifying TLS certificate when no CA is configured

Medium 5.8

In plain English

A medium-severity improper certificate validation in kuma from kumahq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.8Medium
Exploit odds (30 days)0.4%top 71.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kuma is a modern Envoy-based service mesh that can run on every cloud across both Kubernetes and VMs. Prior to 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7, Universal mode kuma-dp connections to an HTTPS control plane disable TLS peer verification when --ca-cert-file is not supplied and KUMA_CONTROL_PLANE_CA_CERT is unset. The dataplane authentication token is sent over the unverified connection, allowing an on-path attacker to intercept the token, impersonate the control plane, inject a forged bootstrap configuration, and take over the proxy. Standard Kubernetes installations created by kumactl install control-plane or the official Helm chart are unaffected because the mutating admission webhook injects KUMA_CONTROL_PLANE_CA_CERT into each sidecar. This issue is fixed in versions 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/kumahq/kumano fix listedGO-2026-6013
Gogithub.com/kumahq/kumano fix listedGHSA-wvmp-6r4v-j6cv
Gogithub.com/kumahq/kuma/v22.11.14GHSA-wvmp-6r4v-j6cv
Gogithub.com/kumahq/kuma/v22.12.11GHSA-wvmp-6r4v-j6cv
Gogithub.com/kumahq/kuma/v22.13.7GHSA-wvmp-6r4v-j6cv
Gogithub.com/kumahq/kuma/v22.7.26GHSA-wvmp-6r4v-j6cv
Gogithub.com/kumahq/kuma/v22.11.14, 2.12.11, 2.13.7, 2.7.26GO-2026-6013
Gogithub.com/kumahq/kuma/v22.9.16GHSA-wvmp-6r4v-j6cv

Affected products (as reported)

VendorProductVersions
kumahq kuma < 2.7.26>= 2.8.0, < 2.9.16>= 2.10.0, < 2.11.14>= 2.12.0, < 2.12.11>= 2.13.0, < 2.13.7

Weakness: CWE-295 · Vector: CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

References