Vulnerability · Published Apr 2, 2026 · Assigned by VulDB

CVE-2026-5244Cesanta Mongoose TLS 1.3 mongoose.c mg_tls_recv_cert heap-based overflow

High 7.3

In plain English

A high-severity heap buffer overflow in Mongoose from Cesanta. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.8%top 44.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability has been found in Cesanta Mongoose up to 7.20. This affects the function mg_tls_recv_cert of the file mongoose.c of the component TLS 1.3 Handler. Such manipulation of the argument pubkey leads to heap-based buffer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.21 mitigates this issue. The name of the patch is 0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12swupdateno fix listedDEBIAN-CVE-2026-5244
Debian:13swupdateno fix listedDEBIAN-CVE-2026-5244
Debian:14swupdate2025.12+dfsg-10DEBIAN-CVE-2026-5244
Ubuntu:22.04:LTSswupdateno fix listedUBUNTU-CVE-2026-5244
Ubuntu:24.04:LTSswupdateno fix listedUBUNTU-CVE-2026-5244
Ubuntu:25.10swupdateno fix listedUBUNTU-CVE-2026-5244
Ubuntu:26.04:LTSswupdateno fix listedUBUNTU-CVE-2026-5244
Ubuntu:26.10swupdateno fix listedUBUNTU-CVE-2026-5244

Affected products (as reported)

VendorProductVersions
Cesanta Mongoose 7.07.17.27.37.47.57.67.7

Weakness: CWE-122, CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C

References