Vulnerability · Published Jun 15, 2026 · Assigned by openjs

CVE-2026-5079multer vulnerable to Denial of Service via deeply nested field names

High 7.5

In plain English

A high-severity uncontrolled resource consumption in multer from multer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 79.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmmulter2.2.0GHSA-72gw-mp4g-v24j
npmmulter3.0.0-alpha.2GHSA-72gw-mp4g-v24j

Affected products (as reported)

VendorProductVersions
multer multer 1.0.0 – before 2.2.03.0.0-alpha.1 – before 3.0.0-alpha.2

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References