Vulnerability · Published Jun 30, 2026 · Assigned by apache
CVE-2026-50750Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Pre-authentication OpenWire DoS following fix for CVE-2026-49270
High 7.5
In plain English
A high-severity uncontrolled resource consumption in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Following the fix for CVE-2026-49270 an unauthenticated attacker can now cause broker OOM by sending an repeated BrokerInfo commands without sending a ConnectionInfo, until the broker will crash with OOM. This issue affects Apache ActiveMQ Broker: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ All: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7. Users are recommended to upgrade to version 6.2.7, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | activemq | no fix listed | DEBIAN-CVE-2026-50750 |
| Debian:13 | activemq | no fix listed | DEBIAN-CVE-2026-50750 |
| Maven | org.apache.activemq:activemq-all | 5.19.8 | GHSA-9qj4-v6r6-3wmx |
| Maven | org.apache.activemq:activemq-all | 6.2.7 | GHSA-9qj4-v6r6-3wmx |
| Maven | org.apache.activemq:activemq-broker | 5.19.8 | GHSA-9qj4-v6r6-3wmx |
| Maven | org.apache.activemq:activemq-broker | 6.2.7 | GHSA-9qj4-v6r6-3wmx |
| Maven | org.apache.activemq:apache-activemq | 6.2.7 | GHSA-9qj4-v6r6-3wmx |
| Maven | org.apache.activemq:apache-activemq | 5.19.8 | GHSA-9qj4-v6r6-3wmx |
| Ubuntu:24.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-50750 |
| Ubuntu:25.10 | activemq | no fix listed | UBUNTU-CVE-2026-50750 |
| Ubuntu:26.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-50750 |
| Ubuntu:26.10 | activemq | no fix listed | UBUNTU-CVE-2026-50750 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ActiveMQ Broker | 5.19.7 – before 5.19.86.2.6 – before 6.2.7 |
| Apache Software Foundation | Apache ActiveMQ | 5.19.7 – before 5.19.86.2.6 – before 6.2.7 |
| Apache Software Foundation | Apache ActiveMQ All | 5.19.7 – before 5.19.86.2.6 – before 6.2.7 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://lists.apache.org/thread/nhkmbdym61yp6wwy0dny8w1p46sm87kr vendor-advisory