Vulnerability · Published Jun 12, 2026 · Assigned by apache

CVE-2026-50633Apache CXF: JNDI Injection vulnerability in DispatchMDBMessageListenerImpl

High 8.1

In plain English

A high-severity improper input validation in Apache CXF from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.9%top 39.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.cxf:cxf-integration-jca4.2.2GHSA-qp3f-rvj8-46c8
Mavenorg.apache.cxf:cxf-integration-jca4.1.7GHSA-qp3f-rvj8-46c8

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache CXF 4.2.0 – before 4.2.24.0.0 – before 4.1.70 – before 3.6.12

Weakness: CWE-20, CWE-502 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References