Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-50556Angular: Missing `<noscript>` Raw-Text Serialization Escaping leads to Cross-Site Scripting (XSS) in Angular SSR

High 8.1

In plain English

A high-severity cross-site scripting in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 64.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of <noscript> elements. When rendering dynamic text content inside a <noscript> element via template bindings (such as {{ value }} or [textContent]), the template engine expects the browser to render the content safely. Under Server-Side Rendering (SSR), domino is configured with scripting enabled, meaning <noscript> is treated as a raw-text element. However, domino's serializer completely omitted <noscript> from the list of raw-text elements requiring closing-tag escaping during DOM serialization. As a result, any occurrence of </noscript> in the bound dynamic text was never escaped under any circumstances. The unescaped closing tag was serialized directly into the output HTML (e.g. <noscript></noscript><script>alert(1)</script></noscript>). When parsed by a browser, it closes the <noscript> block early, allowing the injected <script> block to execute in the user's browser context, causing same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-50556
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-50556
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50556
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50556
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-50556
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50556
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-50556
npm@angular/platform-serverno fix listedGHSA-gxx4-3xcv-f8qx
npm@angular/platform-server19.2.25GHSA-gxx4-3xcv-f8qx
npm@angular/platform-server20.3.24GHSA-gxx4-3xcv-f8qx
npm@angular/platform-server21.2.16GHSA-gxx4-3xcv-f8qx
npm@angular/platform-server22.0.0-rc.2GHSA-gxx4-3xcv-f8qx

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.16>= 20.0.0-next.0, < 20.3.24>= 19.0.0-next.0, < 19.2.25<= 18.2.14

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References