Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-50555Angular: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in @angular/platform-server

High 8.6

In plain English

A high-severity cross-site scripting in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.3%top 81.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of raw-text elements (such as <script>, <style>, and <iframe>). domino supports escaping raw-text elements during serialization to prevent closing-tag breakout. However, a Unicode index alignment bug existed in this escaping logic. In JavaScript, string lengths and character indices are calculated based on UTF-16 code units (where astral characters—such as emojis—occupy 2 code units / 4 bytes). If the bound dynamic text contained astral Unicode characters before the closing tag (e.g. </script>, </style>, or </iframe>), the index offset calculation in domino's replacement logic shifted. This misalignment caused domino to fail to replace or escape the closing tag, leaving it raw and unescaped in the output HTML. An attacker who controls the dynamic text can supply a payload containing both an astral Unicode character and a closing tag (e.g., 😀</iframe><script>alert(1)</script>). When serialized on the server during SSR, the browser parses the unescaped closing tag, exits the raw-text context early, and executes the subsequent <script> block, leading to same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-50555
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-50555
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50555
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50555
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-50555
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50555
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-50555
npm@angular/platform-serverno fix listedGHSA-hqr9-c56f-3x7f
npm@angular/platform-server19.2.25GHSA-hqr9-c56f-3x7f
npm@angular/platform-server20.3.24GHSA-hqr9-c56f-3x7f
npm@angular/platform-server21.2.16GHSA-hqr9-c56f-3x7f
npm@angular/platform-server22.0.0-rc.2GHSA-hqr9-c56f-3x7f

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.16>= 20.0.0-next.0, < 20.3.24>= 19.0.0-next.0, < 19.2.25<= 18.2.14

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References