Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-50184Angular: Request Credential & Cache Policy Stripping in Angular Service Worker

Medium 5.7

In plain English

A medium-severity information exposure in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.7Medium
Exploit odds (30 days)0.2%top 89.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips explicit client-defined safety parameters: the credentials configuration (such as credentials: 'omit') and the HTTP cache mode configuration (such as cache: 'no-store'). These are reverted back to standard browser-default parameters (credentials: 'same-origin' and default HTTP cache properties). This causes the browser to include active credentials (such as cookies or Authorization headers) on outbound requests where the client-side developer explicitly instructed they should be omitted, leading to potential session leaks. Additionally, it causes private or non-cacheable resources to be cached by the service worker's engine, making private page states accessible or persistent inside the client's local cache post-logout. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-50184
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-50184
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50184
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50184
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-50184
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50184
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-50184
npm@angular/service-workerno fix listedGHSA-95qp-cmmw-mgqv
npm@angular/service-worker19.2.23GHSA-95qp-cmmw-mgqv
npm@angular/service-worker20.3.22GHSA-95qp-cmmw-mgqv
npm@angular/service-worker21.2.15GHSA-95qp-cmmw-mgqv
npm@angular/service-worker22.0.0-rc.2GHSA-95qp-cmmw-mgqv

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.15>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.23<= 18.2.14

Weakness: CWE-200, CWE-524 · Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References