Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-50168Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass

High 8.8

In plain English

A high-severity server-side request forgery in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.8High
Exploit odds (30 days)0.2%top 85.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/platform-server package allows remote attackers to bypass host allowlist constraints and direct server-side outgoing requests to arbitrary external endpoints. This occurs due to a parser differential between the strict WHATWG URL parser used for allowlist validation and the lenient Domino URL parser used to initialize the server emulated DOM. When a server-side request contains a malformed URL with a double port structure (e.g., http://evil.com:80:80/path), Node's strict URL.canParse(url) logic returns false and skips host check validation entirely. However, the same malformed URL is later accepted and parsed leniently by Domino's internal parser, which resolves the origin to http://evil.com:80. The Angular SSR HTTP request interceptor (relativeUrlsTransformerInterceptorFn) then resolves all relative backend HTTP requests against this adopted origin, executing the SSRF attack. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-50168
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-50168
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50168
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50168
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-50168
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-50168
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-50168
npm@angular/platform-server21.2.15GHSA-xrxm-cp7j-8xf6
npm@angular/platform-serverno fix listedGHSA-xrxm-cp7j-8xf6
npm@angular/platform-server19.2.23GHSA-xrxm-cp7j-8xf6
npm@angular/platform-server20.3.22GHSA-xrxm-cp7j-8xf6
npm@angular/platform-server22.0.0-rc.2GHSA-xrxm-cp7j-8xf6

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0, < 22.0.0-rc.2>= 21.0.0-next.0, < 21.2.15>= 20.0.0-next.0, < 20.3.22>= 19.0.0-next.0, < 19.2.23<= 18.2.14

Weakness: CWE-346, CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References