Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-50016pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement
High 8.8
In plain English
A high-severity security flaw in pnpm from pnpm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm allows a transitive dependency alias from registry package metadata to contain path traversal segments. During install, pnpm later uses that alias as a filesystem path when linking dependency nodes. As a result, a registry package can cause `pnpm install --ignore-scripts` to replace paths in the current project with symlinks to attacker-controlled dependency package directories. This vulnerability is fixed in 10.34.0 and 11.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | pnpm | 10.34.0 | GHSA-hwx4-2j3j-g496 |
| npm | pnpm | 11.4.0 | GHSA-hwx4-2j3j-g496 |
Affected products (as reported)
Weakness: CWE-23 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-hwx4-2j3j-g496 x_refsource_CONFIRM