Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-50015pnpm: Arbitrary File Write/Delete via Malicious Patch File (Path Traversal)
High 7.3
In plain English
A high-severity path traversal in pnpm from pnpm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm's patch application pipeline (@pnpm/patch-package) performs no path validation on file paths extracted from .patch files. An attacker who contributes a malicious patch file via a pull request can write attacker-controlled content to or delete arbitrary files on the filesystem during pnpm install, as the user running the install. The diff --git header paths containing ../../ sequences traverse out of the package directory, and the traversal is difficult to catch in code review because patch file diff headers are opaque to most reviewers. This vulnerability is fixed in 10.34.0 and 11.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | pnpm | 10.34.0 | GHSA-rxhj-4m44-96r4 |
| npm | pnpm | 11.4.0 | GHSA-rxhj-4m44-96r4 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-rxhj-4m44-96r4 x_refsource_CONFIRM