Vulnerability · Published Jun 2, 2026 · Assigned by GitHub_M
CVE-2026-49443authentik: `UserSourceConnection.user` and `GroupSourceConnection.group` are changeable through the API
High 8.8
In plain English
A high-severity improper authentication in authentik from goauthentik. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities).
Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.3%top 77.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
authentik is an open-source identity provider. Prior to versions 2025.12.6, 2026.2.4, and 2026.5.1, an attacker with the ability to change a source connection, and an account in one of the configured sources can log into any account. This issue has been patched in versions 2025.12.6, 2026.2.4, and 2026.5.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| goauthentik | authentik | < 2025.12.6< 2026.2.4< 2026.5.1 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/goauthentik/authentik/security/advisories/GHSA-wr38-7xg8-fqxr x_refsource_CONFIRM