Vulnerability · Published Jun 30, 2026 · Assigned by apache

CVE-2026-49434Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: LdapNetworkConnector instantiates denied transports and a remote-properties broker

High 7.5

In plain English

A high-severity improper input validation in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 49.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-49434
Debian:13activemqno fix listedDEBIAN-CVE-2026-49434
Mavenorg.apache.activemq:activemq-all5.19.8GHSA-h5gm-rvw6-2xpx
Mavenorg.apache.activemq:activemq-all6.2.7GHSA-h5gm-rvw6-2xpx
Mavenorg.apache.activemq:activemq-broker5.19.8GHSA-h5gm-rvw6-2xpx
Mavenorg.apache.activemq:activemq-broker6.2.7GHSA-h5gm-rvw6-2xpx
Mavenorg.apache.activemq:apache-activemq6.2.7GHSA-h5gm-rvw6-2xpx
Mavenorg.apache.activemq:apache-activemq5.19.8GHSA-h5gm-rvw6-2xpx
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49434
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-49434
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49434
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-49434

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ Broker 0 – before 5.19.86.0.0 – before 6.2.7
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.86.0.0 – before 6.2.7
Apache Software Foundation Apache ActiveMQ All 0 – before 5.19.86.0.0 – before 6.2.7

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References