Vulnerability · Published Aug 19, 2026 · Assigned by GitHub_M
CVE-2026-49283SimpleSAMLphp HTTP-Artifact TLS validator confusion allows cross-IdP authentication bypass
High 8.7
In plain English
A high-severity improper certificate validation in saml2 from simplesamlphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1, the HTTPArtifact::receive() flow can treat an unsigned embedded SAML Response as cryptographically valid for the wrong identity provider. SOAPClient::addSSLValidator() attaches a TLS-based validator to the outer SOAP ArtifactResponse, while the embedded Response receives a validator that delegates to the outer message and is later checked against metadata selected from the embedded response issuer rather than necessarily the artifact issuer. SOAPClient::validateSSL() returns normally when the TLS public key does not match the key being validated, and SAML2\Message::validate() treats a validator call that does not throw as successful. In a multi-IdP federation, a malicious or lower-trust IdP can therefore provide an ArtifactResponse containing an unsigned Response that claims a higher-trust victim IdP as issuer and authenticate as arbitrary users with attacker-chosen assertion attributes, NameID, and session data. This issue is fixed in versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | simplesamlphp | no fix listed | DEBIAN-CVE-2026-49283 |
| Debian:14 | simplesamlphp | no fix listed | DEBIAN-CVE-2026-49283 |
| Packagist | simplesamlphp/saml2 | 4.20.2 | GHSA-6929-8p9f-26jx |
| Packagist | simplesamlphp/saml2 | 5.0.6 | GHSA-6929-8p9f-26jx |
| Packagist | simplesamlphp/saml2 | 4.19.3 | GHSA-6929-8p9f-26jx |
| Packagist | simplesamlphp/saml2 | 6.2.1 | GHSA-6929-8p9f-26jx |
| Packagist | simplesamlphp/saml2-legacy | 4.19.3 | GHSA-6929-8p9f-26jx |
| Packagist | simplesamlphp/saml2-legacy | 4.20.2 | GHSA-6929-8p9f-26jx |
| Ubuntu:24.04:LTS | simplesamlphp | no fix listed | UBUNTU-CVE-2026-49283 |
| Ubuntu:26.04:LTS | simplesamlphp | no fix listed | UBUNTU-CVE-2026-49283 |
| Ubuntu:26.10 | simplesamlphp | no fix listed | UBUNTU-CVE-2026-49283 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| simplesamlphp | saml2 | < 4.19.3>= 4.20.0, < 4.20.2>= 5.0.0, < 5.0.6>= 6.0.0, < 6.2.1 |
Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
References
- https://github.com/simplesamlphp/saml2/security/advisories/GHSA-6929-8p9f-26jx x_refsource_CONFIRM
- https://github.com/simplesamlphp/saml2/commit/4a71b20d8d845579fd0a54d6449c265b40db459d x_refsource_MISC
- https://github.com/simplesamlphp/saml2/commit/a2c1ac588c70d7b7998546cf32675fb113f22a5f x_refsource_MISC
- https://github.com/simplesamlphp/saml2/commit/d5c213132ef671c0018a11252322034dbddd735a x_refsource_MISC
- https://github.com/simplesamlphp/saml2/commit/e2df7992609964951b2a3e7d6566b7427b2a968f x_refsource_MISC