Vulnerability · Published Jun 1, 2026 · Assigned by apache

CVE-2026-49270Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Durable Subscription Disclosure via Crafted BrokerInfo (OpenWire)

Medium 5.9

In plain English

A medium-severity security flaw in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.4%top 69.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-49270
Debian:13activemqno fix listedDEBIAN-CVE-2026-49270
Mavenorg.apache.activemq:activemq-all5.19.7GHSA-hf52-78x8-6w3w
Mavenorg.apache.activemq:activemq-all6.2.6GHSA-hf52-78x8-6w3w
Mavenorg.apache.activemq:activemq-broker5.19.7GHSA-hf52-78x8-6w3w
Mavenorg.apache.activemq:activemq-broker6.2.6GHSA-hf52-78x8-6w3w
Mavenorg.apache.activemq:apache-activemq5.19.7GHSA-hf52-78x8-6w3w
Mavenorg.apache.activemq:apache-activemq6.2.6GHSA-hf52-78x8-6w3w
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49270
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-49270
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49270
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-49270

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ Broker 5.14.0 – before 5.19.76.0.0 – before 6.2.6
Apache Software Foundation Apache ActiveMQ 5.14.0 – before 5.19.76.0.0 – before 6.2.6
Apache Software Foundation Apache ActiveMQ All 5.14.0 – before 5.19.76.0.0 – before 6.2.6

Weakness: CWE-1230 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

References