Vulnerability · Published Jun 1, 2026 · Assigned by apache

CVE-2026-49157Apache ActiveMQ: Authenticated low-privilege Web users retain Jolokia broker-management capability by default

High 8.8

In plain English

A high-severity incorrect default permissions in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.4%top 61.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-49157
Debian:13activemqno fix listedDEBIAN-CVE-2026-49157
Mavenorg.apache.activemq:apache-activemq5.19.7GHSA-99qx-5qqr-4j95
Mavenorg.apache.activemq:apache-activemq6.2.6GHSA-99qx-5qqr-4j95
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49157
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-49157
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-49157
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-49157

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.76.0.0 – before 6.2.6

Weakness: CWE-276 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References