Vulnerability · Published Jul 6, 2026 · Assigned by apache

CVE-2026-49042Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

High 7.3

In plain English

A high-severity improper input validation in Apache Camel from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.7%top 47.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.camel:camel-langchain4j-agent4.18.3GHSA-hh8r-75r6-qrg9
Mavenorg.apache.camel:camel-langchain4j-agent4.21.0GHSA-hh8r-75r6-qrg9
Mavenorg.apache.camel:camel-langchain4j-tools4.18.3GHSA-hh8r-75r6-qrg9
Mavenorg.apache.camel:camel-langchain4j-tools4.21.0GHSA-hh8r-75r6-qrg9
Mavenorg.apache.camel:camel-spring-ai-tools4.18.3GHSA-hh8r-75r6-qrg9
Mavenorg.apache.camel:camel-spring-ai-tools4.21.0GHSA-hh8r-75r6-qrg9

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Camel 4.8.0 – through 4.18.24.19.0 – through 4.20.0

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References