Vulnerability · Published Jun 11, 2026 · Assigned by GitHub_M
CVE-2026-48998guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation
Medium 5.3
In plain English
A medium-severity improper input validation in psr7 from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Versions prior to 2.10.2 contain improper Host header validation when parsing raw HTTP request messages and when deriving a server request URI from server variables. An attacker can provide a malformed Host header containing URI authority delimiters, such as `trusted.example@evil.example`. When the Host value is used to construct a URI, the malformed value can be reinterpreted as URI userinfo and host. This can cause the PSR-7 request URI host to differ from the original Host header value. Applications are affected if they parse attacker-controlled raw HTTP requests with `GuzzleHttp\Psr7\Message::parseRequest()` or the legacy 1.x `GuzzleHttp\Psr7\parse_request()` function, or if they build server requests from attacker-controlled server variables, then rely on the resulting URI host for routing, allow-list checks, or forwarding decisions. In affected forwarding or gateway scenarios, this may cause requests or credentials to be sent to an unintended host. The issue is patched in `2.10.2`. `1.x` is end-of-life and will not receive a patch. Some workarounds are available. Validate the `Host` header as `uri-host [ ":" port ]` before calling `Message::parseRequest()` or legacy `parse_request()` on untrusted HTTP request data, or before deriving routing and forwarding decisions from a parsed request URI. Reject Host values containing userinfo, path, query, or fragment delimiters.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-guzzlehttp-psr7 | 2.4.5-1+deb12u1 | DEBIAN-CVE-2026-48998 |
| Debian:13 | php-guzzlehttp-psr7 | 2.7.1-1+deb13u1 | DEBIAN-CVE-2026-48998 |
| Debian:14 | php-guzzlehttp-psr7 | 2.10.3-1 | DEBIAN-CVE-2026-48998 |
| Packagist | guzzlehttp/psr7 | 2.10.2 | GHSA-34xg-wgjx-8xph |
| Ubuntu:24.04:LTS | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-48998 |
| Ubuntu:25.10 | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-48998 |
| Ubuntu:26.04:LTS | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-48998 |
| Ubuntu:26.10 | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-48998 |
Affected products (as reported)
Weakness: CWE-20, CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/guzzle/psr7/security/advisories/GHSA-34xg-wgjx-8xph x_refsource_CONFIRM