Vulnerability · Published Jun 17, 2026 · Assigned by GitHub_M
CVE-2026-48820CakePHP: View::element() is missing a path containment check
Medium 6.3
In plain English
A medium-severity path traversal in cakephp from cakephp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the application/plugin view template paths. When element names are created with specifically crafted user-supplied data this weakness can be leveraged to include other PHP files on the server. Patched releases are available in 5.3.6, 5.2.13, 5.1.7, 4.6.4, and 4.5.11.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | cakephp/cakephp | 5.3.6 | GHSA-wpvj-hjcr-h3p2 |
| Packagist | cakephp/cakephp | 5.2.13 | GHSA-wpvj-hjcr-h3p2 |
| Packagist | cakephp/cakephp | 5.1.7 | GHSA-wpvj-hjcr-h3p2 |
| Packagist | cakephp/cakephp | 4.6.4 | GHSA-wpvj-hjcr-h3p2 |
| Packagist | cakephp/cakephp | 4.5.11 | GHSA-wpvj-hjcr-h3p2 |
| Ubuntu:22.04:LTS | cakephp | no fix listed | UBUNTU-CVE-2026-48820 |
Affected products (as reported)
Weakness: CWE-98, CWE-22 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/cakephp/cakephp/security/advisories/GHSA-wpvj-hjcr-h3p2 x_refsource_CONFIRM