Vulnerability · Published Aug 11, 2026 · Assigned by GitHub_M

CVE-2026-48813Flawfinder output manipulation via untrusted filenames and source text

High 8.7

In plain English

A high-severity injection in flawfinder from david-a-wheeler. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 61.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Flawfinder is a a static analysis tool for finding vulnerabilities in C/C++ source code. Versions prior to 2.0.20 have an improper input neutralization issue leading to output manipulation, specifically, Terminal/ANSI Escape Sequence Injection and XML Injection. A malicious file whose name contains ANSI escape sequences can end up being included in flawfinder's standard terminal output, with many effects. Untrusted fields (such as filenames, categories, or code context text) were not properly sanitized when generating structured reports. An attacker could exploit this to corrupt CSV formats or inject arbitrary XML attributes into SonarQube outputs via output_sonar(). It impacts those who use flawfinder to evaluate intentionally malicious filenames or file contents. This issue has been fully patched in Version 2.0.20 (released 2026-05-16). There is no configuration-based workaround within older versions of flawfinder. If an immediate upgrade is not possible, users can mitigate the risk by pre-scanning filenames, inspecting raw output, and/or restricting untrusted inputs.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIflawfinder2.0.20GHSA-4c3c-r6p8-c863
PyPIflawfinder2.0.20PYSEC-2026-2480
Ubuntu:22.04:LTSflawfinderno fix listedUBUNTU-CVE-2026-48813
Ubuntu:24.04:LTSflawfinderno fix listedUBUNTU-CVE-2026-48813
Ubuntu:26.04:LTSflawfinderno fix listedUBUNTU-CVE-2026-48813
Ubuntu:26.10flawfinderno fix listedUBUNTU-CVE-2026-48813

Affected products (as reported)

VendorProductVersions
david-a-wheeler flawfinder < 2.0.20

Weakness: CWE-74 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References