Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-48805Twig: Sandbox state regression in deprecated internal wrappers in `src/Resources/core.php`
Medium 5.3
In plain English
A medium-severity security flaw in Twig from twigphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Twig is a template language for PHP. Prior to 3.27.0, deprecated internal wrappers in src/Resources/core.php do not forward the current sandbox state to CoreExtension::checkArrow(), arraySome(), and arrayEvery(), allowing legacy calls such as twig_array_some(), twig_array_every(), and twig_check_arrow_in_sandbox() to bypass sandbox callable restrictions. This issue is fixed in version 3.27.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-twig | no fix listed | DEBIAN-CVE-2026-48805 |
| Debian:13 | php-twig | 3.27.0-0+deb13u1 | DEBIAN-CVE-2026-48805 |
| Debian:14 | php-twig | 3.27.0-1 | DEBIAN-CVE-2026-48805 |
| Packagist | twig/twig | 3.27.0 | GHSA-p42q-9prx-q5wq |
| Ubuntu:25.10 | php-twig | no fix listed | UBUNTU-CVE-2026-48805 |
| Ubuntu:26.10 | php-twig | no fix listed | UBUNTU-CVE-2026-48805 |
Affected products (as reported)
Weakness: CWE-693 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/twigphp/Twig/security/advisories/GHSA-p42q-9prx-q5wq x_refsource_CONFIRM
- https://github.com/twigphp/Twig/commit/e235cae3a1d1e23edc24df4d675f18108c6b167b x_refsource_MISC
- https://github.com/twigphp/Twig/releases/tag/v3.27.0 x_refsource_MISC