Vulnerability · Published Sep 15, 2026 · Assigned by GitHub_M
CVE-2026-48717OpenAM OAuth Authorization Bypass via PKCE Challenge
Critical 9.1
In plain English
A critical-severity security flaw in OpenAM from OpenIdentityPlatform. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.openidentityplatform.openam:openam-oauth2 | 16.1.1 | GHSA-4v2w-2wqp-mc85 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenIdentityPlatform | OpenAM | < 16.1.1 |
Weakness: CWE-285 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-4v2w-2wqp-mc85 x_refsource_CONFIRM
- https://github.com/OpenIdentityPlatform/OpenAM/commit/97a34d9fee17395e8e052bfc45eb5855f436153e x_refsource_MISC
- https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1 x_refsource_MISC