Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M
CVE-2026-48493Snipe-IT Vulnerable to Privilege Escalation for self via API Permissions Assignment
Medium 5.5
In plain English
A medium-severity incorrect authorization in snipe-it from grokability. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Snipe-IT is an IT asset/license management system. In versions prior to 8.6.0, a user with only users.edit can send a PATCH to /api/v1/users/{their_own_id} and grant themselves any permission except admin and superuser — for example `assets.view`, `assets.create`, `reports.view`, import, etc. The issue is patched in version 8.6.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | snipe/snipe-it | 8.6.0 | GHSA-52fw-7fw2-fmv5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| grokability | snipe-it | < 8.6.0 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N
References
- https://github.com/grokability/snipe-it/security/advisories/GHSA-52fw-7fw2-fmv5 x_refsource_CONFIRM
- https://github.com/grokability/snipe-it/pull/19024 x_refsource_MISC