Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-48489Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes

High 8.7

In plain English

A high-severity incorrect authorization in security-http from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.6%top 51.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, DefaultAuthenticationFailureHandler honored the request-supplied _failure_path parameter when failure_forward: true was enabled, allowing an unauthenticated failing login request to dispatch a subrequest to access_control-protected GET routes that skipped firewall listeners. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony5.4.53+dfsg-0+deb12u1DEBIAN-CVE-2026-48489
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-48489
Debian:14symfony7.4.13+dfsg-1DEBIAN-CVE-2026-48489
Packagistsymfony/security-http5.4.53GHSA-6h46-9jf5-q59x
Packagistsymfony/security-http8.0.13GHSA-6h46-9jf5-q59x
Packagistsymfony/security-http6.4.41GHSA-6h46-9jf5-q59x
Packagistsymfony/security-http7.4.13GHSA-6h46-9jf5-q59x
Packagistsymfony/symfony8.0.13GHSA-6h46-9jf5-q59x
Packagistsymfony/symfony5.4.53GHSA-6h46-9jf5-q59x
Packagistsymfony/symfony6.4.41GHSA-6h46-9jf5-q59x
Packagistsymfony/symfony7.4.13GHSA-6h46-9jf5-q59x
Ubuntu:25.10symfonyno fix listedUBUNTU-CVE-2026-48489
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-48489
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-48489

Affected products (as reported)

VendorProductVersions
symfony symfony < 5.4.53>= 6.0.0-BETA1, < 6.4.41>= 7.0.0-BETA1, < 7.4.13>= 8.0.0-BETA1, < 8.0.13
symfony security-http < 5.4.53>= 6.0.0-BETA1, < 6.4.41>= 7.0.0-BETA1, < 7.4.13>= 8.0.0-BETA1, < 8.0.13

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References