Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-48068@grpc/grps-js: A malformed request can cause a server crash

High 7.5

In plain English

A high-severity security flaw in grpc-node from grpc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.9%top 40.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@grpc/grpc-js1.9.16GHSA-5375-pq7m-f5r2
npm@grpc/grpc-js1.10.12GHSA-5375-pq7m-f5r2
npm@grpc/grpc-js1.11.4GHSA-5375-pq7m-f5r2
npm@grpc/grpc-js1.12.7GHSA-5375-pq7m-f5r2
npm@grpc/grpc-js1.13.5GHSA-5375-pq7m-f5r2
npm@grpc/grpc-js1.14.4GHSA-5375-pq7m-f5r2

Affected products (as reported)

VendorProductVersions
grpc grpc-node < 1.9.16>= 1.11.0, < 1.11.4>= 1.12.0, < 1.12.7>= 1.13.0, < 1.13.5>= 1.14.0, < 1.14.4>= 1.10.0, < 1.10.12

Weakness: CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References