Vulnerability · Published Jul 24, 2026 · Assigned by GitHub_M

CVE-2026-48036Hulumi: Drift classifier fails open on adapter errors and over-promotes Mixed verdicts

High 8.4

In plain English

A high-severity security flaw in hulumi from kerberosmansour. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.4High
Exploit odds (30 days)0.5%top 56.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, consumers running drift detection in CI / cron could see transient adapter failures silently cached as "all clear" — masking real attacks for up to six hours — or see ordinary provider-version churn falsely promoted to incident severity. Either way, the verdict source was unreliable for downstream incident workflows that gate on it. This issue has been patched in version 1.4.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@hulumi/drift1.4.0GHSA-32g3-35g9-wc9g

Affected products (as reported)

VendorProductVersions
kerberosmansour hulumi < 1.4.0

Weakness: CWE-755 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L

References