Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-47770jq: stack overflow in deep structural equality
Medium 6.8
In plain English
A medium-severity security flaw in jq from jqlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
jq is a command-line JSON processor. Prior to 1.8.2, comparing two sufficiently deeply nested arrays with the == operator exhausts the C stack on jq's ordinary command-line surface, resulting in denial of service via stack exhaustion (uncontrolled recursion). The crash occurs in jq's recursive structural comparison code, with the recursion repeating through jvp_array_equal() and jv_equal() in src/jv.c when comparing deeply nested arrays; a nearby sort comparator path through jv_cmp() in src/jv_aux.c overflows the stack at a larger nesting depth from the same missing recursion guard. Anyone running jq comparisons on attacker-controlled deeply nested JSON values, or embedding jq in a context where untrusted data can reach the == comparison path, is affected. This vulnerability is fixed in 1.8.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.22 | jq | 1.8.2-r0 | ALPINE-CVE-2026-47770 |
| Alpine:v3.23 | jq | 1.8.2-r0 | ALPINE-CVE-2026-47770 |
| Alpine:v3.24 | jq | 1.8.2-r0 | ALPINE-CVE-2026-47770 |
| Debian:12 | jq | 1.6-2.1+deb12u2 | DEBIAN-CVE-2026-47770 |
| Debian:13 | jq | 1.7.1-6+deb13u3 | DEBIAN-CVE-2026-47770 |
| Debian:14 | jq | 1.8.1-7 | DEBIAN-CVE-2026-47770 |
| Ubuntu:22.04:LTS | jq | no fix listed | UBUNTU-CVE-2026-47770 |
| Ubuntu:24.04:LTS | jq | no fix listed | UBUNTU-CVE-2026-47770 |
| Ubuntu:25.10 | jq | no fix listed | UBUNTU-CVE-2026-47770 |
| Ubuntu:26.04:LTS | jq | no fix listed | UBUNTU-CVE-2026-47770 |
| Ubuntu:26.10 | jq | no fix listed | UBUNTU-CVE-2026-47770 |
Affected products (as reported)
Weakness: CWE-674 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/jqlang/jq/security/advisories/GHSA-3pgx-frr7-3jxp x_refsource_CONFIRM