Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M

CVE-2026-47767Symfony: SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch

High 8.3

In plain English

A high-severity security flaw in runtime from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.3High
Exploit odds (30 days)0.7%top 45.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 5.4.46 until 5.4.52, 6.4.40, 7.4.12, and 8.0.12, the CVE-2024-50340 fix gated runtime argv parsing on empty($_GET), but parse_str() and the web SAPI can disagree, allowing a crafted query string to leave $_GET empty while $_SERVER['argv'] still carries attacker-controlled --env or --no-debug flags that change APP_ENV or APP_DEBUG. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12symfony5.4.52+dfsg-0+deb12u1DEBIAN-CVE-2026-47767
Debian:13symfony6.4.41+dfsg-0+deb13u1DEBIAN-CVE-2026-47767
Debian:14symfony7.4.12+dfsg-1DEBIAN-CVE-2026-47767
Packagistsymfony/runtime8.0.12GHSA-fqc7-9xjw-jrh3
Packagistsymfony/runtime6.4.40GHSA-fqc7-9xjw-jrh3
Packagistsymfony/runtime7.4.12GHSA-fqc7-9xjw-jrh3
Packagistsymfony/runtime5.4.52GHSA-fqc7-9xjw-jrh3
Packagistsymfony/symfony7.4.12GHSA-fqc7-9xjw-jrh3
Packagistsymfony/symfony5.4.52GHSA-fqc7-9xjw-jrh3
Packagistsymfony/symfony6.4.40GHSA-fqc7-9xjw-jrh3
Packagistsymfony/symfony8.0.12GHSA-fqc7-9xjw-jrh3
Ubuntu:26.04:LTSsymfonyno fix listedUBUNTU-CVE-2026-47767
Ubuntu:26.10symfonyno fix listedUBUNTU-CVE-2026-47767

Affected products (as reported)

VendorProductVersions
symfony symfony >= 5.4.46, < 5.4.52>= 6.4.14, < 6.4.40>= 7.1.7, < 7.4.12>= 8.0.0-BETA1, < 8.0.12
symfony runtime >= 5.4.46, < 5.4.52>= 6.4.14, < 6.4.40>= 7.1.7, < 7.4.12>= 8.0.0-BETA1, < 8.0.12

Weakness: CWE-436 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References