Vulnerability · Published May 28, 2026 · Assigned by GitHub_M

CVE-2026-47761TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

High 8.7

In plain English

A high-severity cross-site scripting in tinymce from tinymce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.7High
Exploit odds (30 days)0.3%top 81.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGettinymceno fix listedGHSA-vg35-5wq7-3x7w
NuGettinymce8.5.1GHSA-vg35-5wq7-3x7w
NuGettinymce7.9.3GHSA-vg35-5wq7-3x7w
Packagisttinymce/tinymce8.5.1GHSA-vg35-5wq7-3x7w
Packagisttinymce/tinymceno fix listedGHSA-vg35-5wq7-3x7w
Packagisttinymce/tinymce7.9.3GHSA-vg35-5wq7-3x7w
npmtinymceno fix listedGHSA-vg35-5wq7-3x7w
npmtinymce8.5.1GHSA-vg35-5wq7-3x7w
npmtinymce7.9.3GHSA-vg35-5wq7-3x7w

Affected products (as reported)

VendorProductVersions
tinymce tinymce < 5.11.1>= 6.0.0, <= 6.8.6>= 7.0.0, < 7.9.3>= 8.0.0, < 8.5.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

References