Vulnerability · Published Jul 1, 2026 · Assigned by GitHub_M
CVE-2026-47262containerd image-triggered runtime DoS via unbounded group parsing
Medium 5.3
In plain English
A medium-severity uncontrolled resource consumption in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
containerd is an open-source container runtime. Versions prior to 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2, contain a vulnerability that allows a maliciously crafted image to cause a Denial of Service (DoS) condition. When creating a container from this image, memory exhaustion occurs, leading to an Out Of Memory (OOM) kill of the containerd process. This renders the container runtime API unavailable and can disrupt clients such as the Docker Engine or Kubernetes control-plane components. This issue has been fixed in versions 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.24 | containerd | 2.3.2-r0 | ALPINE-CVE-2026-47262 |
| Debian:12 | containerd | no fix listed | DEBIAN-CVE-2026-47262 |
| Debian:13 | containerd | no fix listed | DEBIAN-CVE-2026-47262 |
| Debian:14 | containerd | 2.1.9+ds1-1 | DEBIAN-CVE-2026-47262 |
| Go | github.com/containerd/containerd | 1.7.33 | GHSA-jpcc-p29g-p8mq |
| Go | github.com/containerd/containerd | 1.7.33 | GO-2026-5475 |
| Go | github.com/containerd/containerd/v2 | 2.0.10, 2.1.9, 2.2.5, 2.3.2 | GO-2026-5475 |
| Go | github.com/containerd/containerd/v2 | 2.1.9 | GHSA-jpcc-p29g-p8mq |
| Go | github.com/containerd/containerd/v2 | 2.0.10 | GHSA-jpcc-p29g-p8mq |
| Go | github.com/containerd/containerd/v2 | 2.2.5 | GHSA-jpcc-p29g-p8mq |
| Go | github.com/containerd/containerd/v2 | 2.3.2 | GHSA-jpcc-p29g-p8mq |
| Ubuntu:22.04:LTS | containerd | 1.6.12-0ubuntu1~22.04.11 | UBUNTU-CVE-2026-47262 |
| Ubuntu:25.10 | containerd | no fix listed | UBUNTU-CVE-2026-47262 |
| Ubuntu:26.10 | containerd | no fix listed | UBUNTU-CVE-2026-47262 |
| Ubuntu:22.04:LTS | containerd-app | 2.2.1-0ubuntu1~22.04.2 | UBUNTU-CVE-2026-47262 |
| Ubuntu:24.04:LTS | containerd-app | 2.2.1-0ubuntu1~24.04.3 | UBUNTU-CVE-2026-47262 |
| Ubuntu:25.10 | containerd-app | 2.2.1-0ubuntu1~25.10.2 | UBUNTU-CVE-2026-47262 |
| Ubuntu:26.04:LTS | containerd-app | 2.2.2-0ubuntu1.1 | UBUNTU-CVE-2026-47262 |
| Ubuntu:25.10 | containerd-stable | 2.1.6-0ubuntu1~25.10.2 | UBUNTU-CVE-2026-47262 |
| Ubuntu:26.04:LTS | containerd-stable | 2.2.2-0ubuntu1.1 | UBUNTU-CVE-2026-47262 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| containerd | containerd | >= 1.7.0, < 1.7.33>= 2.0.0, < 2.0.10>= 2.1.0, < 2.1.9>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.2 |
Weakness: CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/containerd/containerd/security/advisories/GHSA-jpcc-p29g-p8mq x_refsource_CONFIRM