Vulnerability · Published Jun 11, 2026 · Assigned by GitHub_M
CVE-2026-47167Vim: Vimscript Code Injection in cucumber filetype plugin via crafted step-definition regex
Medium 5.1
In plain English
A medium-severity code injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vim is an open source, command line text editor. Prior to version 9.2.0496, a code injection vulnerability exists in s:stepmatch() in the cucumber filetype plugin (runtime/ftplugin/cucumber.vim) on Vim builds with +ruby support. Step-definition patterns read from .rb files under the repository's features/*/ or stories/*/ directories are embedded into a Ruby Kernel.eval argument without sufficient escaping, allowing a crafted pattern in an attacker-controlled repository to execute arbitrary Ruby (and through it arbitrary shell commands) when the user invokes a step-jump mapping ([d, ]d). This issue has been patched in version 9.2.0496.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | vim-X11 | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-X11 | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-X11 | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-common | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-common | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-common | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-data | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:10 | vim-enhanced | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-enhanced | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-enhanced | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-filesystem | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-filesystem | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-filesystem | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-minimal | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-minimal | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-minimal | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | xxd | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-47167 |
| Debian:13 | vim | 2:9.1.1230-2+deb13u1 | DEBIAN-CVE-2026-47167 |
| Debian:14 | vim | 2:9.2.0524-1 | DEBIAN-CVE-2026-47167 |
| Rocky Linux:10 | vim | 2:9.1.083-9.el10_2.7 | RLSA-2026:38509 |
| Rocky Linux:8 | vim | 2:8.0.1763-27.el8_10 | RLSA-2026:38510 |
| Rocky Linux:9 | vim | 2:8.2.2637-26.el9_8.10 | RLSA-2026:38511 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.32 | UBUNTU-CVE-2026-47167 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.16 | UBUNTU-CVE-2026-47167 |
| Ubuntu:25.10 | vim | 2:9.1.0967-1ubuntu6.7 | UBUNTU-CVE-2026-47167 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.5 | UBUNTU-CVE-2026-47167 |
Affected products (as reported)
Weakness: CWE-94, CWE-95 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/vim/vim/security/advisories/GHSA-4473-94jm-w5x9 x_refsource_CONFIRM
- https://github.com/vim/vim/commit/a65a52d684bc58535ad28a4ae824d22e76399934 x_refsource_MISC
- https://github.com/vim/vim/releases/tag/v9.2.0496 x_refsource_MISC