Vulnerability · Published Jun 12, 2026 · Assigned by GitHub_M

CVE-2026-47138Parse Server: Pre-authentication denial of service via client version header regex backtracking

High 8.7

In plain English

A high-severity regular-expression denial of service in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.6%top 51.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.77 and 9.9.1-alpha.1, an unauthenticated attacker who knows a publicly-known Parse Application ID can submit a single HTTP request whose client SDK version field contains adversarial input that triggers polynomial backtracking in a request-header parser. The parsing runs before session authentication and before rate limiting on every /parse/* request, so the request consumes seconds to minutes of synchronous CPU on a Node.js worker before any access control evaluates it. A small number of concurrent requests can saturate a worker; a single large request via the body-field variant can pin a worker for minutes. Production deployments running the default configuration are affected. This issue has been patched in versions 8.6.77 and 9.9.1-alpha.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.9.1-alpha.1GHSA-38m6-82c8-4xfm
npmparse-server8.6.77GHSA-38m6-82c8-4xfm

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.77>= 9.0.0, < 9.9.1-alpha.1

Weakness: CWE-1333 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References