Vulnerability · Published Jun 25, 2026 · Assigned by apache

CVE-2026-46751Apache Kvrocks: Does not remove the unsafe loadstring function from its Lua sandbox, allowing a user who can run EVAL scripts to load crafted, unvalidated bytecode that crashes the server process, resulting in a remote denial of service.

Medium 5.5

In plain English

A medium-severity security flaw in Apache Kvrocks from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).

Severity (CVSS 4.0)5.5Medium
Exploit odds (30 days)0.3%top 74.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from 2.2.0 through 2.15.0. Users are recommended to upgrade to version 2.16.0, which fixes the issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Kvrocks 2.2.0 – through 2.15.0

References