Vulnerability · Published Jun 26, 2026 · Assigned by GitHub_M
CVE-2026-46710Notepad++: Privilege Escalation in the Installer via Uncontrolled Executable Search Path
High 7.5
In plain English
A high-severity security flaw in notepad-plus-plus from notepad-plus-plus. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 4% of all known vulnerabilities).
Official description
Notepad++ is a free and open-source source code editor. From 8.9.4 until 8.9.6, Notepad++ contains a local privilege escalation vulnerability in the installer. During installation, the installer invokes powershell.exe without using an absolute path after setting the working directory to the installation contextMenu directory. If an attacker can pre-place a malicious powershell.exe in a user-writable custom installation directory, and a privileged user later runs the installer and selects that directory, the attacker-controlled executable is launched with the elevated privileges of the installer. This vulnerability is fixed in 8.9.6.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| notepad-plus-plus | notepad-plus-plus | >= 8.9.4, < 8.9.6 |
Weakness: CWE-426 · Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N