Vulnerability · Published Jun 10, 2026 · Assigned by GitHub_M
CVE-2026-46654Plonky3 MultiField32Challenger: transcript malleability and challenge entropy loss
High 8.9
In plain English
A high-severity insufficient verification of data authenticity in Plonky3 from Plonky3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 1% of all known vulnerabilities).
Severity (CVSS 4.0)8.9High
Exploit odds (30 days)0.1%top 98.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Plonky3 is a toolkit for polynomial IOPs (PIOPs). Prior to versions 0.4.3 and 0.5.3, an attacker controlling prover-side observations can craft distinct transcripts that produce identical challenges, breaking the binding property of Fiat-Shamir. This issue has been patched in versions 0.4.3 and 0.5.3.
Affected products (as reported)
Weakness: CWE-1240, CWE-345 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N
References
- https://github.com/Plonky3/Plonky3/security/advisories/GHSA-vj64-rjf3-w3v7 x_refsource_CONFIRM