Vulnerability · Published Jun 8, 2026 · Assigned by GitHub_M
CVE-2026-46444Flowise: Vector Store No Permission Checks
High 8.7
In plain English
A high-severity missing authorization in Flowise from FlowiseAI. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, all CRUD endpoints for OpenAI Assistants Vector Store have no authentication middleware and the route path /api/v1/openai-assistants-vector-store is not in WHITELIST_URLS. However, it is also not protected by the main auth middleware when accessed via API key — the route requires API key auth (not whitelisted), but no permission checks exist on any operation. This issue has been patched in version 3.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.2 | GHSA-hmg2-jjjx-jcp2 |
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-hmg2-jjjx-jcp2 x_refsource_CONFIRM
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2 x_refsource_MISC