Vulnerability · Published Jun 8, 2026 · Assigned by GitHub_M
CVE-2026-46443Flowise: Credential Data Leak
High 7.0
In plain English
A high-severity information exposure in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, when credentials are fetched with a credentialName filter parameter, the encryptedData field is not stripped from the response. The code properly omits encryptedData when no filter is used but fails to do so when a filter is used. This issue has been patched in version 3.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.2 | GHSA-7g73-99r4-m4mj |
Affected products (as reported)
Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-7g73-99r4-m4mj x_refsource_CONFIRM
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2 x_refsource_MISC