Vulnerability · Published Jul 15, 2026 · Assigned by GitHub_M

CVE-2026-46421Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)

Critical 9.3

In plain English

A critical-severity security flaw in @cap-js/postgres from cap-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)0.5%top 55.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/sqlite@2.2.2`, `@cap-js/postgres@2.2.2`, and `@cap-js/db-service@2.10.1` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@cap-js/db-service2.11.0GHSA-pvw4-cvr4-97p8
npm@cap-js/postgres2.3.0GHSA-pvw4-cvr4-97p8
npm@cap-js/sqlite2.3.0GHSA-pvw4-cvr4-97p8

Affected products (as reported)

VendorProductVersions
cap-js @cap-js/sqlite = 2.2.2
cap-js @cap-js/postgres = 2.2.2
@cap-js/db-service @cap-js/db-service = 2.10.1

Weakness: CWE-506 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References