Vulnerability · Published Jun 9, 2026 · Assigned by GitHub_M
CVE-2026-46373SQLFluff: Recursive Stack Overflow in Parser
High 7.5
In plain English
A high-severity security flaw in sqlfluff from sqlfluff. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
SQLFluff is a modular SQL linter and auto-formatter with support for multiple dialects and templated code. Prior to version 4.1.0, in deployments where untrusted users can provide SQL queries to be linted, an untrusted user can submit a malicious query with deliberate excessive nesting to any application using the parser to trigger a Denial of Service through resource exhaustion. This issue has been patched in version 4.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | sqlfluff | no fix listed | DEBIAN-CVE-2026-46373 |
| Debian:13 | sqlfluff | no fix listed | DEBIAN-CVE-2026-46373 |
| Debian:14 | sqlfluff | 4.3.0-1 | DEBIAN-CVE-2026-46373 |
| PyPI | sqlfluff | 4.1.0 | GHSA-wmhf-fqc8-vxhh |
| PyPI | sqlfluff | 4.1.0 | PYSEC-2026-209 |
| Ubuntu:24.04:LTS | sqlfluff | no fix listed | UBUNTU-CVE-2026-46373 |
| Ubuntu:25.10 | sqlfluff | no fix listed | UBUNTU-CVE-2026-46373 |
| Ubuntu:26.04:LTS | sqlfluff | no fix listed | UBUNTU-CVE-2026-46373 |
| Ubuntu:26.10 | sqlfluff | no fix listed | UBUNTU-CVE-2026-46373 |
Affected products (as reported)
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/sqlfluff/sqlfluff/security/advisories/GHSA-wmhf-fqc8-vxhh x_refsource_CONFIRM