Vulnerability · Published Jul 15, 2026 · Assigned by GitHub_M
CVE-2026-45805Penpot: MCP REPL server binds to 0.0.0.0 with unauthenticated /execute endpoint — RCE
High 8.8
In plain English
A high-severity security flaw in penpot from penpot. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Penpot is an open-source design tool for design and code collaboration. Prior to 2.15.0, Penpot MCP's mcp/packages/server/src/ReplServer.ts bound the ReplServer to 0.0.0.0:4403 and exposed an unauthenticated /execute endpoint that passed the code field to PluginBridge.executePluginTask(), allowing anyone on the network to execute JavaScript on the server. This issue is fixed in version 2.15.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @penpot/mcp | 2.15.0 | GHSA-22qr-rp27-j9wm |
Affected products (as reported)
Weakness: CWE-749 · Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/penpot/penpot/security/advisories/GHSA-22qr-rp27-j9wm x_refsource_CONFIRM
- https://github.com/penpot/penpot/issues/9518 x_refsource_MISC
- https://github.com/penpot/penpot/commit/798ee46b4a84ee6dfc756b001f33acbe0280d62f x_refsource_MISC
- https://github.com/penpot/penpot/releases/tag/2.15.0 x_refsource_MISC