Vulnerability · Published Jun 11, 2026 · Assigned by GitHub_M
CVE-2026-45802FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service
Medium 6.0
In plain English
A medium-severity resource allocation without limits in FPDI from Setasign. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | setasign/fpdi | 2.6.7 | GHSA-2mgw-7q6p-8grg |
Affected products (as reported)
Weakness: CWE-770, CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/Setasign/FPDI/security/advisories/GHSA-2mgw-7q6p-8grg x_refsource_CONFIRM
- https://github.com/Setasign/FPDI/commit/1695cfcc7e01fe844a7296b3de90855a3fa65be6 x_refsource_MISC
- https://github.com/Setasign/FPDI/releases/tag/v2.6.7 x_refsource_MISC