Vulnerability · Published May 21, 2026 · Assigned by apache
CVE-2026-45760Apache Camel K: Camel K Cross-Namespace Build Deputy Attack
High 8.1
In plain English
A high-severity authorization bypass via user-controlled key in Apache Camel K from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
(Externally Controlled Reference to a Resource in Another Sphere), (Authorization Bypass Through User-Controlled Key) vulnerability in Apache Camel K. Authorized users in a Kubernetes namespace can create a Build resource, controlling the Pod generation in a namespace of their choice, including the operator namespace. This issue affects Apache Camel K: from 2.0.0 before 2.8.1, from 2.9.0 before 2.9.2, from 2.10.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1 (or 2.8.1 or 2.9.2), which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/apache/camel-k | no fix listed | GO-2026-5573 |
| Go | github.com/apache/camel-k/v2 | 2.8.1 | GHSA-q8ch-jx67-q52x |
| Go | github.com/apache/camel-k/v2 | 2.9.2 | GHSA-q8ch-jx67-q52x |
| Go | github.com/apache/camel-k/v2 | 2.10.1 | GHSA-q8ch-jx67-q52x |
| Go | github.com/apache/camel-k/v2 | 2.10.1, 2.8.1, 2.9.2 | GO-2026-5573 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Camel K | 2.0.0 – before 2.8.12.9.0 – before 2.9.22.10.0 – before 2.10.1 |
Weakness: CWE-610, CWE-639 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N