Vulnerability · Published Jun 18, 2026 · Assigned by GitHub_M

CVE-2026-45696OpenEXR HTJ2K decoder heap buffer over-read in ht_undo_impl() (DoS)

High 7.1

In plain English

A high-severity heap buffer overflow in openexr from AcademySoftwareFoundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.4%top 63.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. In versions 3.4.0 through 3.4.11, the HTJ2K (High-Throughput JPEG 2000) decoder, ht_undo_impl() in OpenEXRCore is vulnerable to a heap-buffer-overflow READ. The ht_undo_imp function copies decoded pixels out of a per-line OpenJPH buffer using the EXR channel's declared width as the iteration count. The codestream embedded in the EXR chunk can declare different (smaller) tile/line dimensions than the EXR header advertises, but ht_undo_impl() does not validate this — it pulls width 32-bit samples from cur_line->i32[] without checking the OpenJPH line buffer's actual length. A crafted EXR file produces a 4-byte heap-buffer-overflow READ immediately after a buffer allocated by ojph::local::codestream::finalize_alloc(). The bug is reachable through the standard scanline-decode entry point used by every consumer of exr_decoding_run/Imf::checkOpenEXRFile, including thumbnailers, asset pipelines, and the exrcheck utility — i.e. any application that opens untrusted EXR files. The result is a deterministic crash (DoS) and potential adjacent-heap leak. This issue has been fixed in version 3.4.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23openexr3.4.13-r0ALPINE-CVE-2026-45696
Alpine:v3.24openexr3.4.13-r0ALPINE-CVE-2026-45696
Debian:14openexr3.4.14-0.1DEBIAN-CVE-2026-45696
Ubuntu:25.10openexrno fix listedUBUNTU-CVE-2026-45696
Ubuntu:26.10openexrno fix listedUBUNTU-CVE-2026-45696

Affected products (as reported)

VendorProductVersions
AcademySoftwareFoundation openexr >= 3.4.0, < 3.4.11

Weakness: CWE-122, CWE-125 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

References