Vulnerability · Published May 29, 2026 · Assigned by GitHub_M
CVE-2026-45660Statamic: Server-Side Request Forgery via Glide
Medium 5.4
In plain English
A medium-severity server-side request forgery in cms from statamic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.22 and 6.18.1, the Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints. This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected. This vulnerability is fixed in 5.73.22 and 6.18.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | statamic/cms | 5.73.22 | GHSA-pf9c-ch8r-2958 |
| Packagist | statamic/cms | 6.18.1 | GHSA-pf9c-ch8r-2958 |
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
References
- https://github.com/statamic/cms/security/advisories/GHSA-pf9c-ch8r-2958 x_refsource_CONFIRM